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1. Introduction

This document is a brief introduction to the K Desktop Environment. It will familiarize you with
some of the basic features of KDE.

This guide is far from covering all aspects of the K Desktop or even most of them. It will only
describe some of the most basic ways to accomplish a few of the most common tasks.

We assume that you are already familiar with at least one graphical user interface, for example
CDE(tm), Geos(tm), GEM(tm), NeXT(tm), MacFinder(tm), Presentation Manager(tm) or
MS-Windows(tm). So we will not explain the usage of the mouse or the keyboard but
concentrate on hopefully more interesting things.
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2. An Overview of KDE

This section is for users who prefer to learn by exploring and want only a brief orientation to get
started. Later sections provide a more thorough introduction to the environment, with helpful
hints and shortcuts. If you are impatient to get started, skim this section, go play for a bit, then
come back and peruse the other sections of this guide as needed.

Note: KDE provides a highly configurable desktop environment. This overview assumes that
you are using the default environment.

2.1 The KDE Desktop

A typical KDE desktop consists of three areas:
A panel at the bottom of the screen, used to start applications and switch between
desktops. Among other things, it contains the Application Starter, a large "K" icon which
displays a menu of applications to start when clicked.

●   

A taskbar at the upper-left corner of the screen, used to switch between and manage
currently running applications. Click on an application on the taskbar to zip to the
application.

●   

The desktop itself, on which frequently used files and folders may be placed. KDE
provides multiple desktops, each of which has its own windows. Click on the numbered
buttons on the panel to switch between desktops.

●   

2.2 Ready, Set, Go!

Here are a few quick tips to get you up and running.
To start an application, click on the "K" button on the panel (called the Application Starter)
and choose an item from the menu.

●   

Click the icon that looks like a folder with a picture of a house on the taskbar to access
the files in your home directory using kfm, KDE's File Manager utility.

●   

Choose Application Starter > Utilities > Terminal to get a Unix command prompt, or
press Alt-F2 to get a mini command prompt window to execute a single command.

●   

Choose the KDE Control Center item on Application Starter to configure KDE.●   

Press Alt-Tab to switch between apps and Ctrl-Tab to switch between desktops using the
keyboard.

●   

Use the right mouse button to access context menus for the panel, desktop, and many
KDE applications.

●   
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3. Launching Applications

3.1 Using the Application Starter and the Panel

On the bottom of the screen you find the desktop panel. You use the panel to launch
applications. Have a look at the button on the left with a large K. This button is called the
Application Starter. It has a small arrow on the top to indicate that it will pop up a menu if you
click on it. Just do it! The popup offers you easy access to all KDE applications installed on
your computer system.

Shortcut: Alt-F1 opens the Application Starter menu.

Customizing the Panel

If you use one application or tool very often, then you may want to have even faster access to
it, of course. In this case, you can add a single application or an entire sub-menu of the
Application Starter menu as a special quick-launch button onto the panel. If you want to reach
the "Find Files" directly via a launch button, simply choose application starter > Panel > Add
Application > Find Files (By this we mean that you should first click the Application Starter,
then select "Panel" where the small arrow to the right indicates that another menu will pop up.
In this menu, choose "Add application" and in the next sub-menu, "Find Utility".). Note that you
can move all items of the panel around with the "move" command of the context menu. Just
click with the third mouse button (the third mouse button is normally the right button, but if you
have configured your mouse for left-handers e.g., it might also be the left one). A menu will pop
up where you can choose "Move". Now move the mouse and see how the icon follows while
still staying on the panel. When you are done, simply hit the first mouse button (by default the
left one). As you have may have noticed, there is also a menu entry "Remove" in case you are
tired of a certain launch button on your desktop.

Using Context menus

This leads us to another interesting topic: in many places, you can click the right mouse button
to display a context menu with choices that are applicable to the item you clicked. It is therefore
always a good idea to try out the third mouse button on something, if you do not know what to
do with it. Even the background of the desktops has such a menu!

Other Panel features

There are other interesting things possible with the panel. One may be important if you have a
low resolution on your monitor: it is the "hide-and-show"-function, activated by clicking on the
textured bar on the left edge of the panel. By the way, if you are not sure what a certain button
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does in KDE, just move the mouse pointer over it and wait for a short while: KDE has a built-in
mini context help, called "tooltips", which explains the functionality of such controls in a few
words.

3.2 But I want my command line back!

Just calm down, there is nothing to fear. KDE does not want to take your beloved (and
sometimes very effective) command line away from you. You can move your files with the
desktop, but you can also use the Unix commands you are accustomed to. KDE provides a
very sophisticated command line window called kvt. Choose application starter > Utilities >
Terminal to start it. This may be something you want on your panel!

Sometimes, you only want to enter one command on the command line. In these cases, you do
not need a full-blown terminal. Just hit Alt-F2 and you get a small command line where you can
enter one command. The command line window will disappear afterwards, but it remembers
your command. When you pop up this window (which we call "minicli" by the way) and hit the
Up-arrow, you can browse through all the commands you have previously entered. Also, you can
enter URL's in minicli to open a kfm window with the specified URL. A final tip: to display a Unix
man page, enter man:command in minicli, where command is the name of a Unix command.
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4. Working with Windows

If you have not already done so, start an application using the Application Starter, like "Find
Files".

4.1 A window! What now?

Well, usually people work inside windows, but sometimes you may want to manipulate
windows. Here's a quick overview of some of the most common window-related functions:

Move a window: Drag the window's titlebar, or hold the Alt key down and drag anywhere
in the window.

●   

Resize a window: Drag the window's border, or hold the Alt key down and drag with the
right mouse button anywhere in the window.

●   

Maximize a window: Click the maximize button in the titlebar (the square next to the X)
to make the window fill the screen, or to shrink the window back to its original size if
maximized. Clicking with the middle mouse button maximizes the window vertically; the
right button, horizontally.

●   

Iconify a window: Click the iconify button in the titlebar (next to Maximize) to hide the
window. Get it back by clicking the window's icon in the taskbar.

●   

Switch between windows: Aside from the usual mouse click to switch to another
window, you can use Alt-Tab to switch windows. See below for more techniques.

●   

Titlebar buttons

KDE windows have some pretty standard buttons on their titlebars which give you fast access
to some common operations. The default button layout looks like this:

On the left side:
a menu button. This usually shows a mini icon for the application. Click on it to get a
window operations menu.
Shortcut: Alt-F3 opens the window menu.

●   

a sticky button, with a picture of a tack. What the heck is this? Stay tuned!●   

On the right side:
an iconify button.●   

a maximize button.●   

a close button. This closes the window.
Shortcut: Alt-F4.

●   
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Switching between windows

Now that we know how to deal with windows we encourage you to open some other windows
with the panel since we will now discuss how to switch between different windows. Since this is
such a common activity, KDE offers several ways to do it; pick your favorite!

Many window systems require you to click the mouse in another window to begin using it. This
is KDE's default behavior, termed "ClickToFocus" focus policy. But you can also configure your
desktop in a way that moving the mouse pointer onto a window will activate it. This is called
FocusFollowMouse. If you select this policy using the KDE Control Panel, the window under the
mouse pointer is always the active one. It doesn't necessarily come to the front automatically,
but you can still click onto the titlebar or the border of a window or -- a KDE special -- you can
use the Alt key and click the middle mouse button anywhere on the window to raise it.

Here are some other methods to switch windows:
Pick a window from the window list menu. To open the menu, click the middle mouse
button on an empty area of the desktop; click the icon with several windows on the panel;
or press Ctrl-Esc.

●   

Hold down the Alt key and press Tab to cycle through the windows.●   

Use the taskbar (see below).●   

4.2 Using the Taskbar

The taskbar displays a list of small icons, one for each window on the desktop. In the default
KDE setup the taskbar is located in the top left corner, but it can also be located at the top or
the bottom of the screen.

The taskbar is very powerful: A simple click with the left mouse button on the appropriate
taskbar button will bring you to the selected application immediately. Click an entry with the
middle mouse button to iconify/deiconify a window. Last but not least, the right mouse button
will pop up a context menu, with window operations for the selected window.

4.3 Using Virtual Desktops

Now, what was that "sticky" thing?

It may happen that you have more windows open than space on your desktop. In this case you
have three possibilities:

Leave all windows open (cluttered desktop)1.  
Iconify those windows which you do not need at present and use the taskbar or Alt-Tab to
switch between them (still a bit confusing and much work!)

2.  

Recommended: Do what a real operating system does if there is not enough physical
memory: Use virtual memory, in this case virtual desktops.

3.  

Item 3 is the way to go! KDE can handle several different desktops, each with its own windows.
The default configuration provides four desktops. You can switch between the virtual desktops
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easily with a click on one of the desktop buttons on the panel. Also Ctrl-F1...F8 will send you to
the corresponding desktop immediately, or Ctrl-Tab will cycle through the desktops. Finally, if
you move the mouse to a corner of the screen and hold it there briefly, KDE will switch to the
desktop in the direction you indicated.

Virtual desktops are very nice. But sometimes you want a window to be present on every
desktop. This could be for example a small chat window or a alarm clock or whatever. In this
case you can use the above mentioned "sticky"-button which will pin the window on the
background so that it will appear on every virtual desktop.

The sticky button can also be used to move a window from one virtual desktop to another one:
push the sticky pin on the window, switch to a different desktop, and release the pin by pushing
it again. But it is easier if you use the context popup menu of the window's entry in the taskbar
(menu item "Onto current desktop") or the "Send to" option on the window operations menu.
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5. Managing your files

A common metaphor of graphical desktops is the use of folders to represent directories on your
hard disk. Folders contain files and other folders. A KDE application called kfm, the K File
Manager, uses this metaphor to help you manage your files.

5.1 Using kfm

The first time you start KDE, a window with lots of icons in it appears. This is a kfm window
displaying the files in your home directory (the area where your personal files are stored). The
pathname of the folder is displayed under the window's toolbar. If you don't see such a window
now, click the icon on the panel that looks like a folder with a picture of a house.

To open a file or folder, simply click it once with the left mouse button. Clicking the folder with
two dots (..) takes you back one directory level. You can also choose View > Show Tree from
the menu to display the folder hierarchy for more direct navigation. Or you can edit the path
displayed under the toolbar, using the tab key to complete directory names, to get to a specific
directory quickly.

Opening Files

KDE comes with a set of applications to view and edit many common kinds of files, and when
you click a file containing, say, a document or image, kfm will start the appropriate application
to display the file. If it doesn't know what application to start to open a file you clicked, kfm will
prompt you for the name of the application to run.

Technical Note: kfm uses MIME types to associate files with applications.

Dragging and Dropping Icons

To copy or move a file, simply drag its icon to the desktop, to another kfm window, or to a folder
icon. When you release the button, kfm displays a menu to allow you to choose to copy, move,
or create a link to the file. Note that if you choose to create a link, KDE creates a Unix "symbolic
link" (not a "hard link"), so if you move or delete the original file, the link will be broken.

Many KDE applications also support drag and drop operations: you can drag an icon onto a
window of running application, or onto an icon of an application that is not started, to have the
application open the file. Try it!

Setting File Properties

To change file properties, such as its name and permissions, right-click the icon and choose
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Properties from the menu.

5.2 Working with Archives and Networks

In the near past, you needed special software to access files on the Internet. Not any more!
KDE supports a technology called "Network Transparent Access" (NTA) which allows you to
work with files on the other side of the earth as easily as those on your local hard disk.

For example, to access files on an FTP server, just choose File > Open Location from a kfm
menu, and enter the URL of an FTP server. You can drag and drop files to and from the folders
on the server just as if they were on your local disk. You'll even be able to open files on the FTP
server without having to copy them to your local disk (KDE does it for you when necessary).

Note that kfm uses anonymous FTP access, which may restrict your access to files on the FTP
server. If you have an account on the server, you can supply your user ID as part of the URL,
like this:

ftp://userid@server/directory

kfm will prompt you for your password, and if the login succeeds, you will have full access to
your files on the server.

If you are used to the WinZip(tm) utility on MS-Windows(tm), then you will be happy to hear that
KDE can look into tar archives, too. It treats such archives just like a normal folder -- you can
browse into the archive, open files, etc. In general, accessing files on the Internet and in
archives should look and feel just like accessing files on your local disk, except for delays
imposed by the network.

5.3 Using Templates to access Applications and Devices

One of the folders KDE places on your desktop when you log in the first time is called
Templates. It holds a number of files with a .kdelnk extension (not shown). These kdelnk files
are used to represent the following in KDE:

Applications●   

Printers●   

Mountable Devices (e.g. floppy drives)●   

Internet resources (e.g. WWW documents, FTP directories)●   

Nearly every item in the Application Starter and on the panel refers to a kdelnk file on disk. The
kdelnk file specifies what icon to display, as well as specific information about what the icon
represents (an application, device, or URL). You can drag any kdelnk file to the panel to create
a quick-launch button.

Setting up printers

You can create icons for your printers so that you can print a file by dragging it to a printer icon.

An Invitation to KDE: Managing your files

http://www.kde.org/documentation/quickstart/index-5.html (2 of 3) [14/09/1999 10:28:05]



Here's how:
Open the Templates folder located on the desktop.1.  
Drag the Program icon in the folder to the desktop. Choose Copy from the menu that
appears when you drop the icon.

2.  

Right-click the new icon, and choose Properties from the context menu.3.  
On the General tab, change the name to Printer.kdelnk.4.  
On the Execute tab, enter the following in the first Execute field:
lpr %f

Note: This example assumes that you print using the lpr command. If you use a different
command, enter the one you use.

5.  

Still in the Execute tab, click the icon that looks like a cog, and select the Printer icon from
the list that appears.

6.  

Now you should be able to drag a file to the Printer icon and have it printed on your default
printer.

Mounting devices

Unix provides access to storage devices other than the primary hard disk through a process
called mounting. KDE uses kdelnk files to allow you to easily mount, unmount, and access files
on secondary storage devices such as floppy drives and CD-ROM drives.

As an example, here are the steps needed to create an icon to access files on a floppy disk:

Note: Many systems require you to be logged in as root to mount and unmount devices.
Open the Templates folder located on the desktop.1.  
Drag the Device icon in the folder to the desktop. Choose Copy from the menu that
appears when you drop the icon.

2.  

Right-click the new icon, and choose Properties from the context menu.3.  
On the General tab, change the name to Floppy.kdelnk.4.  
On the Device tab, enter /dev/fd0 as the Device. Click the Mounted Icon, and select the
picture of a floppy disk with a green light. Then click the Unmounted Icon and select the
picture of a floppy disk without the green light.

5.  

Now, place a properly formatted floppy in the drive and click the Floppy icon to have KDE
mount the floppy drive and display the files on the disk. Before removing the disk from the
drive, right-click the Floppy icon and choose Unmount from the menu.

Next Previous Table of Contents

An Invitation to KDE: Managing your files

http://www.kde.org/documentation/quickstart/index-5.html (3 of 3) [14/09/1999 10:28:05]



The K Desktop
Environment

Next Previous Table of Contents

6. Configuring your desktop

If you do not like something about the way the desktop looks or operates, you can probably
change it. KDE is very configurable and you can change almost every aspect of the
appearance and the behavior of your desktop. Unlike many other Unix desktop environments,
you do not have to edit cryptic configuration files, either! You use the KDE Control Center, a
special program for configuring your desktop.

6.1 Using the KDE Control Center

Launch the Control Center from the Application Starter. A window with two panes appears,
displaying a list of modules in the left pane. Open a module by clicking the "plus" sign next to
the module or by double-clicking the module name. Then, click one of the module category
names to edit its configuration in the right pane.

Changing the configuration is fairly straightforward. A help button is available on each
configuration panel to explain settings that are not obvious. Each panel has buttons labeled Ok,
Apply, and Cancel, which work as follows:

Ok applies configuration changes and closes the configuration panel.●   

Apply applies configuration changes and leaves the current panel open so you can make
other changes.

●   

Cancel closes the current panel without applying changes.●   

Note: If you make changes on one configuration panel and move to a different module without
clicking Ok or Apply first, your changes will be lost.

6.2 Configuration Modules

Here is a brief overview of the configuration modules:
Applications - contains settings for the Desktop Manager and the Panel (which includes
virtual desktop configuration).

●   

Desktop - contains settings related to the appearance of the desktop, such as
background color/image, window colors, screen saver, fonts, and language.

●   

Information - displays information about memory usage and the system CPU.●   

Input Devices - contains settings for the keyboard and mouse.●   

Network - contains network-related settings.●   

Sound - contains system sound settings.●   

Windows - contains settings governing window appearance and behavior, such as the●   
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focus policy, titlebar buttons, and window animation.

Go ahead! Explore the configuration possibilities and discover the flexibility of KDE.
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7. Logging out

We sincerely hope that using the KDE gives you so much fun and pleasure that you never want
to log out. But if you do, simply click the small X-like button on the panel, just above the padlock
button.

7.1 Session Management

When you log out, KDE remembers which applications you had open, as well as where all the
windows were located, so that it can open them for you the next time you log in. This feature is
termed Session Management. KDE-aware applications will restore themselves to the state they
were in when you logged out: for example, kedit remembers which file you were editing.
Non-KDE applications do not memorize their state on logout, and KDE will warn you to make
sure that you have saved any important data in them when you start to log out.

To illustrate session management, choose application starter > Applications > Editor to start
KEdit. Open a text document to edit. Now log out and back in. You will observe that KEdit will
be restored to the exact same position on the screen, including the right virtual desktop and the
document we left open in KEdit before we logged out is opened again automatically. KEdit will
even remember whether you had unsaved changes to your document before you logged out
and will save them to the file you were working on if you choose 'Save' from the 'File menu'.
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8. KDE an exciting Journey

We hope you enjoyed this brief tour of the K Desktop environment and that this unique desktop
environment will help you get your work done faster and more comfortably than ever.

Please remember that the KDE project is not a commercial venture, but rather a project run by
volunteers from all over the world. We would like to invite you to join the KDE project and
become part of this unique network of people. If you are a programmer you might consider
helping us write KDE applications. If you are an artist or have experience with graphic design,
consider creating icons sets, color schemes, sound schemes and logos for KDE. If you enjoy
writing we would love for you to join our documentation project, KDP.

As you can see there are many ways in which you can help. You are cordially invited to join this
world-wide network of people dedicated to making KDE the best desktop environment for any
computer. Please visit www.kde.org for more information.

Welcome aboard on this exciting journey.

Your KDE Team
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9. Advanced Topics

9.1 Mime Types

KDE comes with a number of MIME types predefined, but you can add your own MIME types
by choosing Edit > Mime Types in a kfm window. Then choose File > New > Mime Type, give
a name to the type, right-click the new icon, choose Properties, and edit the entries on the
Binding tab.
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